x

Windows 10 voit mon second disque dur SSD comme un disque amovible ou une clé USB

 
14/10 16:33 #1
Bonjour aux internautes

J’ai un drôle de problème technique que je n’arrive pas à résoudre sur un nouveau PC portable Asus qui comprend 2 emplacements disque dur SSD que j’ai acheté avec le configomatic de top achat. Il s’agit d’un problème de notification que je n'arrive pas à résoudre après avoir installé sous Windows 10 familial.

Mes deux disques durs sont bien reconnus par Windows 10, sinon je n’aurai pas de système d’exploitation, mais le second apparait comme disque amovible et Windows me demande dans la barre de notification si je souhaite retirer mon disque dur en toute sécurité. On dirait qu’il le confond avec une clé USB alors qu’il ne se trouve pas sur un port USB.

Si vous avez des idées pour corriger ce problème qui n’empêche pas le fonctionnement de mon système, mais qui pourrait peut-être le ralentir vu qu’il considère mon disque du SSD comme une clé USB et donc un périphérique qui va moins vite dans les débits du coup.

Merci pour vos réponses.

Christophe Gayer

PS Je me suis permis de poser ma question sur ce forum ayant déjà eu de bonnes solutions par le passé avec un PC Dell et Windows 7.

Christophe Gayer
anonyme
anonyme
Groupe :
Visiteur
Publicité
Publicité
anonyme
14/10 16:49 #2
Bonjour Christophe Gayer,

Bon, sans référence PC compliqué d’apporter une réponse complète, mais tu peux déjà commencer par vérifier que dans le gestionnaire de périphérique, dans Contrôleurs de Stockage, que la propriété du contrôleur n’ait pas la case « Enable safely remove disk » en français « Activer le retrait du disque en toute sécurité ».

Si cette option n’existe pas, il va falloir regarder dans le bios UEFI si ce dernier ne propose pas une option pour activer ou désactiver le HotPlug sur le contrôleur de tes disques durs. Là, il va falloir faire un tour sur le mode d’emploi du bios de la carte mère présent dans ton portable, elle se trouve sur le site Asus Support si tu n’as pas eu de livret avec ton matériel.

Dans certains cas, le fait de mettre à jour ou d'installer les drivers Intel Rapid Storage Technology corrige le problème.

Enfin, certains proposent d’ajouter une clé de registre dans le système afin de dire tout simplement à Windows de ne pas considérer le disque comme un disque amovible, problème rencontré avec le mode AHCI. Cela se fait en quelques minutes après avoir bien sûr effectué une sauvegarde du registre ( créer un point de restauration fera l’affaire aussi... normalement ) et en ajoutant au registre une clé supplémentaire avec la commande :
reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d 1\02

Le lien pour les explications :
https://www.seeyar.fr/fixer-disque-dur ... aissant-disque-ejectable/

Il y a aussi une autre clé pour modifier la gestion du disque dur dans Windows chez mdkart :
reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\ChannelX" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001

Le lien pour les explications :
http://mdkart.fr/blog/ahci-disque-dur-peripherique-externe/

La dernière solution (celle des clés de registre) est à réaliser en toute connaissance, même si cette clé ne semble pas avoir une incidence sur le fonctionnement de Windows, car modifier le registre Windows peut amener des problèmes de démarrage ou de stabilité du système.

Quand tu montres la lune du doigt, l'imbécile regarde le doigt.
cthierry
Tsonaute
membre
Inscrit
12/07/2002 08:37
De
Seine et Marne
Groupe :
Webmaster
Messages
14391
 
Vous avez trouvé cette réponse utile ? Partagez-la !